RWK Release

The RwK Gold master for Android is currently submitted and is propagating.  If no problems show up overnight, I will open it to general release tomorrow.  (You won't be able to connect to makermall without the new version).

iOS is submitted and waiting for Apple approval.

Makermall has been cleared and is ready for uploading.



  • edited January 19
    This is a monunentous moment in the history of RwK!! We're keeping our fingers crossed for a revamped iOS version after all your other projects gets done ;)
  • How long does Apple usually take to approve/when can I realistically download this onto my iPhone
  • Oh shoot I didn't read that correctly, so the iOS version is already done and dusted?! Cool kitty!
  • @kyleseglin The Apple approve process take 1 or 2 business days. So Monday or tuesday, the game should be able on IOS
  • @fnanfne: Yes the IOS version is already done and dusted :)
  • Hoooooooray
  • Eek! I was hoping for some more advanced notice as there are still quite a few levels I want to immortalise but hey can't stand in the way of progress hooray
  • Apple has been REALLY fast lately on approval.  There is probably a decent chance that they'll approve it sometime tomorrow and I can release it.  Otherwise, it'll be Monday.

    I'll still be leaving the old Kitty Connect level sharing up for about a month while I export all the levels, so if you continue to use the old version on iOS you'll have access there.

    Note: Upgrading WILL destroy all your levels on iOS.  Upload anything you want to keep into Kitty Connect on the old version, and I will be providing some info on how to get those levels for re-sharing after I update Boneyard.
  • Oh I see. I guess I will just lose my old levels because it sounds like all the changes will render them unplayable anyway.
  • It will... BUT, probably some of it is just a matter of replacing, say, one way walls with the sticky walls.  But one reason for me not converting the old levels myself is because too much reliance on glitches and errors renders them gone.

    However, if you share them into Kitty Connect, I will be able to get you the levels, at least, so that you can modify the ones that are easily modifiable, without having to recreate them completely.

    In general, though, Apple's 64-bit conversion has been disastrous for any of my file formats that were not text files.  A tiny bit of backwards compatibility from Apple, from time to time, would be very welcome.  I wrote Hamsterball on Windows ME and it still can run on Windows 10!
  • @raptisoft,
    I was just making a level that used a lot of velcro blocks and after a bit the blocks have reverted to the older velcro block (the second gen grid block, not the first gen one) and it seems there's no way to make them into the new version. Erasing and replacing doesn't do it. If I erase some of the blocks that displayed properly they can only be replaced by the purple grid velcro block. Any ideas why? Could it be a number thing? Like, there's a limit on the velcro blocks?

  • Update: I found a work around. It seems when I try to paint over the velcro blocks that have reverted (with any paint set, even lava) they turn back to single velcro blocks, with the new graphic (but each one an individual square). I can then select the velcro tile again and draw over them to make them join. It's a bit convoluded, but it works.
  • edited January 21
    Just some observations...

    1) Crystals don't show total amount picked up, only 1.
    2) Lava kills the robot when it's flashing red.
    3) Game crashes almost ceaselessly when revisiting an unfinished level. (I get it to load okay upon the 5th-or-so relaunch)
    4) When facing left (or right) before launching the robot and then moving right (or left) mid-launch, the robot will continue to face left (or right) so in effect moving backwards mid-air. The robot used to abide by these directional movements
  • @fnafne:

    1) Will be fixed in the update
    2) Intended.  The premise of "kill yourself, then use the immortality time to bypass an obstacle" is a player-hostile exploit that can cause new players to abandon the game (or write me e-mails telling me someone uploaded a level that can't be won).  I am working toward complete consistency here for players so that the game doesn't require a new player to read Nintendo Power's Konami Code Issue.
    3) Hm... I'll have to look into that.  Got any logcats for me? I'll PM you.
    4) Is this consistent?  A quick test with a simple test level here worked correctly, is there a special condition involved?
  • 2) Interesting. I never thought of this to be a glitch/bug. I assumed that when the robot flashes red, he's completely indestructible for a few seconds, no ifs/buts. It feels kinda strange that he is with respect to everything else but not lava though so not consistent as you say.
    3) I have been struggling with getting logcats a few times but will try again.
    4) yes. If you look at the simplisticly boring level I uploaded and launch upwards to get the two bitcoins, you'll see what I mean.
  • On 2), it's more that this encouraged some VERY unfriendly (to players) levels.  When a player has to "know all the tricks" to play the vast majority of levels, that's no longer a glitch, it's a crucial gameplay problem.
  • #23: I still occasionally get no music when testing levels.

    #24: The electric velcro powerup is displayed as a green note block in the pause menu.

    #25: When a red monster touches a wall at the exact same time the platform under it disappears, it gets stuck instead of falling down like it should. This requires really precise timing, so I uploaded a simple level called "Red Monster Bug" in order to make it easier to reproduce.

    #26: Through sheer coincidence, I encountered another bug in this level. Red boss monsters that only have access to a single platform rapidly turn around all the time.

    #27: The number of times a level has been won doesn't seem to increase when I beat it.

    #4 has not been fixed.

    #28: Much like Mahjong Blitz, this game also doesn't always register that I've purchased the ad removal, so I seem to be having this problem with all your games.
  • I've seen #24 as well

    Just on again from 2), have a look at my all time favourite level from Fomb called "Idle Hands". The whole intro of this level is using the mechanics of 2) This is actually the first ever level I played when I bought Kitty Connect and I was like WTF? I revisited the level quite a few times again, spanning years before completing it but was obviously taken aback at first. However, this is the level that got me hooked on RwK, tbh!

    Not that peeved as I'm sure we'll be able to tweak this ourselves with the scriptor?
  • Just another thing I've noticed, 5) I guess, when searching for a level, the order is flipped. So when arranging from oldest to newest, it actually returns newest to oldest.
  • Yeah, I agree with @fnanfne,
    I never thought of the lava walking as a glitch. It seems in most games where a moment of invincibility happens things like this are the norm. I think a lot of players instinctively test the boundaries of their invincibility in these circumstances too. Also, it can happen so easily by accident that anyone playing even for a short time will figure it out. So now it seems kind of inconsistent now: invincible, but not really invincible. 
    Too, when I showed this one to my nephew (who was 5 at the time), he thought it was the coolest thing that he could walk on lava. Played the same level a dozen times just to do it. Tried to see where else he could do it. I know a sample of one is not terribly scientific, but I'm guessing he and I and everyone commenting here represent the general feeling on lava walking. How can lava walking not just be cool? People love it.
    Also, this one will invalidate more levels than the loss of the barrier I'm guessing.
  • @fnanfne,
    Thank you for the kind words! I'm so glad you like that level. If we get the lava walking back I'm make you an Idle Hands II.
  • edited January 21
    #29: Pressing the "Done" button while entering a comment results in a newline.

    #30: When entering a particularly long comment, there doesn't seem to be any way to see the whole thing before posting it.

    #31: There's no way to directly get back to the profile screen from the message screen. This is inconsistent with the "Manage Account" screen where this can be done.

    #32: An option to edit comments shortly after posting them would be nice.
  • Oh, about the crystal number not being displayed. On my device, when I have 2 or 3, I can actually see the very bottom of the number at the top of the screen, like the number is high above the crystal and almost completely off screen.
    Just in case that's helpful for figuring out why, it might just be a placement issue.
  • Got it... will address some of this stuff in the update (some of it I will let go if it doesn't actually harm anything-- this IS a six year old game...)
  • Regarding the lava change, couldn't you just make lava flicker like the robot while he's invincible? That should make it obvious that there's a connection.
  • >couldn't you just make lava flicker like the robot while he's invincible?

    Levels with lots of lava would have to come with epilepsy warnings.

  • Then how about reducing the rate of flickering?
  • Hi there, I was really happy to see the update today, it's the oldest game on my phone(s), I've had it since around 2011 and it was one of the main reasons why I haven't updated to iOS 11, so I'm glad you didn't just let it die. However I'd like to say that I miss the trigger lock "feature" and I agree that the walk on lava was really cool and helpful at times. I'm sure things will fall into place over the next updates, in the meantime, thanks for the update and to long time level creators like Fomb who's levels are most of my favorites.
  • @azaelrdz,
    Thankyou! It makes me happy you like my levels! I hope you like the new ones too, and there's a possibility some (or all) of the old ones might show back up in the new version.
    Thanks for playing!

    p.s. I agree about the lava walking and trigger lock, wholeheartedly. :)
  • @raptisoft, I'm not sure where the best thread is to report issues, but I have had RWK crash when messing with my profile, changing the pic. It's about a 3 times out of 4 that it crashes and oddly the same thing was happening to me on Hoggy 2.

    And also I did notice it seems the oldest/newest level selection is switched. I have to select oldest levels to see the most current ones.
Sign In or Register to comment.